API Help - "Group Not Found" message

Hello,

I’m new to the API here, I’m testing a sample call to create items on a board - but when I call to the API I’m getting a message back stating “Group Not Found”. Here is the board I’m trying to add an item to:

I’m trying to add it with the following query:

mutation {
create_item (board_id: 455625781, group_id: "leads", item_name: "King Arthor", 
             column_values: "{\"phone_number\":\"2182134567\",\"bike\":\"B01231231\",\"created_date\":\"2019-02-10\"}") {
  id
    }
}

I’m getting back the error:
{
“error_code”: “ResourceNotFoundException”,
“status_code”: 404,
“error_message”: “Group not found”,
“error_data”: {
“group_id”: “leads”,
“board_id”: 455625781
}
}

I’ve tried renaming the group to all lowercase - tried different groups on this board, many different things, but no matter what I do, I get the “group not found” error - please help!

I was able to figure this out from support - if you’re having the same issue, the name of the group is not what you need - you need the ID of the column instead. Its best to query to determine what the column id’s and group id’s are in this case.

1 Like