App Webhook

Hi folks,
I’m receiving web hooks on my app but the web hook data structure is slight different from the one defined here:


	"exp": 1693915983,
	"dat": {
		"client_id": "....",
		"user_id": .....,
		"account_id": ....,
		"slug": "...",
		"app_id": ...,
		"app_version_id": ...,
		"install_id": ....,
		"is_admin": true,
		"is_view_only": false,
		"is_guest": false,
		"user_kind": "admin"

Any suggestions?

The app is not listed on the marketplace.


Hello there @rmrodrigues and welcome to the community!

Would you be able to please send this over to with an explanation on which webhook you are receiving (with which event) and the app ID, so we can take a closer look from there?

Looking forward to hearing from you via email!


1 Like

That is the payload of the JWT. const payload = jwt.verify(authHeader, clientSecret), payload would have the structure you showed.

The data structure you are seeing in the documentation, is the body of the request.

Thank you @codyfrisch!

That might be the case here @rmrodrigues. But you can still reply in our email thread if you want!


In this case, the body is empty.



1 Like

How are you generating the webhook? You should be generating it when you install/uninstall the app from the “install” section (on the left menu, one item below “webhooks”).

That’s exactly what I’m doing. I think this worked in the past.

Still does for me.

Only other “obvious” thing is confirm you’re using https not http for the URL. I don’t think that would cause this for the body, but its only thing I can think of that could cause it. Beyond that its either some sort of issue on the monday side, or something odd on your backend.

If you find an answer let us know, in case anyone else encounters it.

Hello there,

We are taking a look into it with our R&D team :grin:

1 Like

Hi there.
I’ve deleted the app and created a new one. This has solved my issue. So, now I’m receiving events correctly.


1 Like

Thank you for sharing this @rmrodrigues !

1 Like