Column(s) view settings fields don't work

I’m trying to get a column selection field working for a custom app I’m developing but no matter what I can’t seem to get it to work. At best it shows “Board and Group”

Otherwise it shows nothing at all. Doesn’t matter what the settings are or which Board I’ve selected for the app.

I have tried everything but I can’t figure out what to do. Even creating an app from scratch yields nothing better for me. Looking for any help here at all.

1 Like

Hello there @davidnairn,

That looks odd. Which columns do you have in that board? Does your user have full access to everything in that board?

What happens if you test this in an actual board instead of the preview mode? Does it work properly then?

Do you see any errors in the console of your browser’s inspector when you try to use this feature?

Would you be able to send a screen recording of the steps you are taking when creating a new app and adding this? Please do not include any sensitive information.


Hey Matias,

Here’s the board’s columns

I’m the user and I have full access to all boards and gave the app full permissions.

I’ll try a build today and see if it works outside of preview mode.

Only console error is a 406 fail to load this file apps/manage/10050758/app_versions/10072965/app_features/10138058/section/~monday-ui-style/dist/index.min.css

Here’s the recording…

Hello again,

Thank you for sending that information.

Can you let me know what happens when you test it in a board? Please try it in at least 2 boards with columns in them.

Also, can you please show me what your test board looks like, and can you please tell me what happens if you use another board in the preview?

Looking forward to hearing from you :slightly_smiling_face:


Okay so it DOES work as a build on a live board. I used the WordCloud sample app to start from scratch. You can see here that the column select doesn’t work in the PREVIEW

And then after creating a production build and testing on a live board.

The drop down is as expected.

The app still seems to function correction regardless but the preview UI is what seems to be broken. I can’t imagine there’s much I can do on my side to fix this?

Oh and here’s the test board

Just to add a bit more information. I setup a personal Monday account and created an app there and it worked as expected. So whatever the problem is it seems restricted to my business Monday account.

Hello again @davidnairn,

I am glad you can test this in real boards!

Would you be able to send us an email to with your email and the name of your account, mentioning this community topic so we can get your information and open a report about the preview feature?


1 Like