CREATE Group API v1 route not working

Hello there,

I just tried this route with multiple boards and keep having the same issue. I have a 201 response code telling me eveyrhting worked fine. But the group is always missing int the targeted board. Support keeps telling me “we only offer limited support for API”. I am lost with this API route kind of not working…

If anyone can help in here?Here is what I am doing,

The request:

curl --location --request POST '{{mykey}}' \
--header 'Cookie: __cfduid=d2876a2b90aac34ec978a44a15004f0fc1590655189' \
--form 'title=test title'

The response: 201 CREATED

"pos": 0.0,
"title": "ddd",
"color": "#037f4c",
"id": "ddd"

Hey @tomgoirand! I have a couple of thoughts.

First off, have you tried making the call via our testing environment at The testing environment will let you test the API call and also return a request URL that you can use for future API calls.

More generally though, I would recommend building using our newer GraphQL API. It exposes a method to create a group on a board. Our REST API will be deprecated on Oct 1, 2020.

Yes I did it using this interface for API V1.

Problem is no longer an issue. Looks like the same request is now served, I would suggest to look into API issue yesterday same time.

1 Like

Hey @tomgoirand – great to hear. We didn’t see any widespread issues yesterday, but we’ll take another look.