Create_item with column_values ignores the values and just create the item

I use the graph try-it-yourself and the item in the board is create without the columns values, no error too
This is my request, the name of the field is in Hebrew

mutation {
create_item (board_id:2741432713, item_name:“test02”, column_values:
“{“שם סעיף תקציב”:“שם סעיף תקציב”}”)
{
id
}
}

The response is
{
“data”: {
“create_item”: {
“id”: “2831461223”
}
},
“account_id”: 5226483
}

hi @leokushnir

Welcome to the community. The most important part (what is given as column_values) is not readable very good. From the looks of it you are not escaping the inner double quotes with a backslash.

In the copy paste it hide it
mutation {
create_item (board_id:2741432713, item_name:“test02”, column_values:
“{\“שם סעיף תקציב\”:\“שם סעיף תקציב\”}”)
{
id
}
}
When I post the message it miss, but there is a back slash

Hello @leokushnir and welcome to the community!

I hope you like it here :muscle:

It looks like you might not be passing the column ID in “column values” correctly.

Here is an example:

column_values: “{“text” : “My Item”}”

In this case, “text” would be column’s ID (Not the title, but the ID). “My Item” would be the value you want to populate the text column with.

You can find the column IDs by clicking on the dropdown button next to each column’s title.

If you can’t find it, then you have to click on your profile picture, then click on “monday labs” and enable the developer mode.

Let me know if this helps!

Cheers,
Matias