Creating an item using mutation create_item works but the item doesn't show in the board

After creating a new item with

mutation {
    create_item (
        board_id: 1234567890,
        item_name: "new item for testing 20230620T2341"
    ) { id } }

And verifying it exists, using the simple “items” query, I was expecting the item to appear in the board UI but it is not there.

I refreshed the page and it didn’t help.
I also tried the “search everything” and it didn’t find the new item.
It only shows in the graphql results.

I also tried duplicating an item from the board, since I thought, maybe there are columns or fields I needed to set to make it work. So I used:

mutation {
    duplicate_item ( board_id: 1234567890, item_id: 234234234 ) {

With similar results: the item was created successfully and I could see it using the graphql query, but it is not showing in the board and the “search everything” fails to find it.

hi @amih

Welcome to the community! Your GraphQL is perfectly fine. I tested the same on my account and the newly created item did show up immediately in the UI. I suggest to email support on this one.

1 Like

Hello @amih I have replied on our email thread :grin:

For anyone finding this issue, the solution was a permission issue.
The API key used wasn’t from the same user which I was using to view the board.
The solution is to add permissions or create an API Key from the user I want to see the items.