Dynamic mapping

Hi Team,
We are working on the functionality which has two way sync of monday.com with our application
While creating the recipe for it we are using the dynamic mapping functionality, and linking it with a custom action. After that we are creating a recipe which has a custom trigger and a custom action which is linked with custom field.
We are facing an issue on this and getting a blank displayed instead we want the columns to be displayed of a monday board
I have attached the screenshot of it, please let us know what is the thing we are missing

The Things we want →

The things we are getting →


Really Excited to take apart of this action with custom field mapping but we will need to find the solution to this error first!

Hello @rachitagl

I have the same problem,
Didi you find the solution? Or did you get any help from Monday.com team?

Thanks for answer in advance!

@dipro Hello,

I have the exact same problem that is described here.
Will you be able to have a look and give me the insights how to solve?

Thanks in advance!

Just as a hail mary, have you tried using a different browser? Some of the mapping functionality does not work correctly in certain browsers, in my experience.

I’d recommend trying Chrome.

@FrancisElliott thanks for the reply.

I was trying only with Chrome.
Then I tried with other browsers as well but no luck.

Hey y’all, sorry for the radio silence here. Our technical team only checks the #developers section of the community, so we missed this.

If you’re building an app and you see this, it’s probably because the Field Definitions URL is sending us an error. Check if your endpoint is working and returning the correct data to us.

Here’s why:

  • Your app defines the fields it supports for mapping and returns them via the field definitions URL.
  • When a user clicks the mapping dialog, monday will send a request to your field definitions URL to get which fields it should display to the user
  • If it gets an error response (eg a 4XX, 5XX status code) it will show the “failed to load fields” error.

Let me know if that helps!

EDIT: I’m going to move this topic into the developers section, so we can keep an eye on it!

@dipro Hello. Thanks for the answer.

There was no problem with the endpoint, we checked it.

Problem still remains the same.

p.s. (replying from another account, because apparently there is a limit that user can reply to the topic max 3 times)

okay, now we made a progress. @dipro
We can map fields,
but we can’t add automation to the board, it shows the error.

here’s the new topic opened for that

Alright, will reply there.

1 Like