Error: Query has depth of 9, which exceeds max depth of 6


I’ve had a workflow running on quite a simple query for a month or so, only just this week it’s starting to come back with an error:

“Query has depth of 9, which exceeds max depth of 6 at line: 2865 called from: 2877 called from: 3190 called from: 2602 called from: 226 called from: 1246 called from: 2846 called from: 2883 called from: 3187 called from: 2602 called from: 226 called from: 1246”

The API call is relatively simple;

mutation {
create_board (board_name: “xxx”, board_kind: public, template_id: 123456789, workspace_id: 1234567, folder_id: 12345678 ,board_owner_ids: [12345678,12345679]) {

Any ideas what am doing wrong? Or anything I can change to fix?

Hi Rob,

Thanks for bringing this to our attention.

I was unable to reproduce this error by running the mutation provided.

Could you please submit this issue to
We might require account information for a potential bug investigation.

Hello @Robbsimmons,

I checked this with our team.

Can you please try naming your mutation “IntrospectionQuery”

mutation {
    board_name: "Name"
    board_kind: public
    template_id: 1122334455
    workspace_id: 123456
    folder_id: 1111122222
    board_owner_ids: [101010101]
  ) {

Please let me know how that works for you!

Looking forward to hearing from you!


Thanks @Matias.Monday , sadly I tried the inclusion of IntrospectionQuery and it didn’t work for me. Still getting the same error!

Any other ideas?

Hello again @Robbsimmons,

Would you be able to please send an email to with this information + the link to this thread so we can take this as a ticket over there?

We might need to create a report about this.

Looking forward to hearing from you over there!