Force US Phone numbers in Phone Column

When enter a phone number into the phone column (not a text box), the phone number is being parsed as an international number. I’ve tried several formats and I don;t know what I’m missing. Is there a way to force all number entered to be recognized as a specific country (USA for me)?

Thanks for the help!

Anybody here?

Where can I get answers to Monday questions?

Hey @malameel - welcome to community an extension of the family.

for the quickest way to get answer to your questions you can got to

If you can’t to seem to find the answer there you can email us at to get a response within hours!

Our community is where you can go and see what other users of the platforms have discovered and can show others.

In your specific use case, there is not a way to force the column to only display one country but you can remove the flag:

Head over to the column’s setting:

And then choose to show or hide it:

I do want to check to see if this is a bug though. Can you email into with the board in questions so we can test out those phone numbers?