How do you limit the emails that are added to monday.com to only those relevant to a deal?

We are tracking leads, deals, contacts, and accounts in monday.com, including deals with existing customers. Because we have integrated monday.com with Outlook, all our email traffic with customers goes into the “emails-and-activities” section of the deal, account, and contact. Because these are active customers, we have a lot of email traffic with them – only a few of these are relevant to a new deal.

Are there ways to filter what gets added to monday.com? I see the setting for “never log” for an email address or domain, but am wondering if there is a way to “selectively log” based on a keyword or something else.

Thanks in advance for any insights!

3 Likes

This is an issue that we are also facing so would be interested in understadning how to address this.

We have the same email addresses in the CRM and Work Management, and get muliple copies of the same email. As we expand this is going to become a nightmare especially to limit the information that this seen between sales and operations.

2 Likes

Hey @RossMartin and @IDM!

Not sure if this is the most elegant option, and it has its limitations, but what I do is use the Outlook template 'When an email is received, create an item in group".

Screenshot 2024-03-08 at 1.37.00 PM

When you go to setup the automation there will be a couple dropdowns where you can filter based off email subject/body/sender/receiver and then choose whether the email does/does not include or is/is not a specific value. And from there, you add the specific values you need to filter into the ‘Add value’ dropdown/text box.

It’s tedious, but the way I used this was to filter out spam emails from coming into our lead board. So, I went through our spam sender list and added all the email senders as a separate ‘condition’ on this automation.

P.S. If anyone knows if it is possible to add multiple/different values to one condition (i.e. multiple emails to the ‘Add value’ box) and have this still work, please let me know. I couldn’t get that to work which is why I added each email as a separate condition, but I have wondered if it’s simply a formatting issue on my part that I’m not aware of.