How to pick a non-business day on date column?

Apparently a recent date-picker update to one of the accounts I use, has made it impossible to pick days that aren’t business days! Other accounts are fine.
image

Mousing over them gives a :no_entry_sign:cursor and typing the date in causes it to jump back to the nearest business day.

Does anyone know where the setting is to reenable non-business days, or what is causing this behavior? It can’t be a new general behavior in testing… something has to be controlling it.

hi @codyfrisch

I believe this is directly derived from the work schedule setting (avatar > administration > general)

Thats what I assumed to start with… however

Have you checked this?

It’s definitely frustrating that this is an account-wide setting.

That appears to be the involved setting, thanks. Which of course makes no mention of this affecting the date picker (previously it seemed to always just gray weekends, but still allowed selections on weekends).

the rollout of new features is a little bit messy because monday uses a controlled rollout based on random pick (x % of the accounts). It appears that this account did get the new date picker but not yet the new working schedules. And how do those two (“weekends” ans “work schedules”) work together :slight_smile: .

Also the new date picker does NOT react to changes in the monday TZ setting, instead it changes time in the UI on device TZ changes.

It gets more and more confusing

Yes. Though, my opinion, user level TZ settings should not affect the UI. Device display settings should then control the display of that time in local time AND local formatting. All the data on the backend, API, etc. should be in UTC. OR if local time it should be an ISO timestamp with offset.

The user level settings should apply to how dates in updates and notifications are posted - which obviously today are one thing that DOESN’T get formatted based on user settings.