Problems with caldera forms

Hi i am using monday. caldera forms and zapier. My problem is that the values gatherered from the form in zapier wont be inserterd into monday. I have set all fields in caldera forms as text fields and all fields in monday as text fields. And sometimes it works! Thats strange I have not find any difference on those who works and those who doesnt… Hmm

Please could someone help me or give advice?

Best regards Johan

Hey @Johan_justvalue :awve

Thanks for reaching out to us! My warmest welcome to the community and I hope you enjoy your stay.

Would you be able to provide a screenshot of the way your Zapier integration is set up? I’d love to see the way this is working both for cases when the value isn’t sent through, and a case when the value is sent through without issues.

-Alex

First 2 screenshots goes through

Its from “runs” went through without problems

Data out

data:

create_item:

id:

1347913487

account_id:

<b>8926347

</b>

These screenshots deosnt work

Please note that the address are classified

I know that there is an error therre but its still the same configuration…

Best Regards

@Johan_justvalue

Thanks so much for getting back to me here! That does look a bit odd - it seems like both of the data sets should go through without issues. Would you be able to provide a screenshot of the way your Zap is set up? I’d love to see the way the column value data is added in, and if there’s anything we can adjust to prevent errors in the future.

I’d also love to understand if the address data is being sent to a Location column, or a text column? The Location column would expect to see latitude and longitude values, and not just the address, so I’m wondering if that could be part of issue.

-Alex

is this what you were looking for?

The address field is at text field…

Best regards

Johan

@Johan_justvalue

Thank you for getting back to me here! I appreciate the clarification.

Would you be able to try and add quotes around the values you are sending? Something like the below might work better:

I also recommend adding a display text value for the email column. You can simply add the same value again, or add a generic display text to show up:

-Alex

ok. but it gets its data from a text column to a text column

@Johan_justvalue

To clarify, the column type you are sending the email address value is a Text column? If so, you won’t need to add the display text in that case. I would also recommend reaching out to Zapier to see if they can clarify any further as well.

-Alex

Yes its text in both caldera, zapier - i hope and monday

I reached out to zapier

And here is what I got as answer…
"
Hi Johan,

I understand you might have different configurations set, but the way Monday.com has built the integration requires the JSON format.

If you have problems with the JSON formation, I would recommend reaching out to the Monday.com team as they will be the best to guide you.
"
Could you guide me pls?

@AlexSavchuk

Hi Alex, I dont know if you saw my last anser with quote from zapier… Is there any posibility for you to help me?

@Johan_justvalue

I’ve just checked our Logs further and it seems like the error is coming from the PostNummer column. Based on your screenshot, it seems like you are sending numerical values to the column, whereas the Text column will always expect a string of text:

Would you be able to try adding quotes around the value you are passing? This should do the trick:

If not, would you be available for a short screen share session so we could troubleshoot and investigate further together? Just let me know and I’d love to set up the screen share further via email.

-Alex

@AlexSavchuk

It worked! Im sening text only because of caldera forms ways of treating numbers

But i am also sending text to phone number and that works without “”.

Strange.

Hi @Johan_justvalue! Glad to hear it’s working for you now.

Hmm unsure why it’s working for the phone number column without quotation marks because that column type does require string formatting.

In any case, let us know if you have additional questions or concerns at this time!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.