Query by column value not working

I am attempting to query an item by column value, and am not getting a return value. Below is the code, and the response:

query { items_by_column_values (board_id: 000000000, column_id: "name", column_value: "1001200 (Michael  Andert)"){ id name } }


  "data": {
    "items_by_column_values": []

I am positive that the item exists and is named exactly what is shown in the query. You can search for this project within the monday browser app, and it comes back as a full text match.

When I run a board query and return all items, the repsonse indludes:

            "id": "2802943814",
            "name": "1001200 (Michael  Andert)"

Seems like the search by column value api endpoint has a bug.

Hello there,

Matias here!

That is strange. I just tested this and it worked for me:

But if you want to send us an email to appsupport@monday.com, we can take a closer look and do some following from there.


Hey Matias,

Strange indeed, I tried it about 5 times last night, over a span of 20 or 30 minutes to try to rule out network or server outages, but it kept returning an empty array. It was happening with about a dozen or so items. It seems to be working this morning though.


1 Like