Status Column API still Broken

I understand looking through past threads that the status column has experienced some bugs. Can someone tell me if the status column is working correctly under the create item mutation? I cannot get a status column to be populated either by index or label. I always get a 500 returned. Thanks.

@deceiver08 – Hey Devin, we are currently not experiencing any bugs with the status column – and updating it should work.

Can you share the query you are using so the folks on the community can better understand what’s going on and help troubleshoot?

Hi @dipro-monday.com. Here is snapshot of my column as well as my mutation code. Everything posts correctly when I do not include the last column (which is my status column).
image

mutation {create_item(board_id: 520559058, group_id: "new_group", item_name: "new item", column_values: 
        "{\"guid\":\"Sample text\",\"objectid\":\"42\",\"mission_description\":\"testtesettest\",\"name8\":\"dummy name\",\"date_submitted\": { \"date\" : \"2019-01-20\" },\"division\":{ \"label\" : \"operations\" },\"section_work_group\":\"Tech Services\",\"phone\":\"503-993-6270\",\"email\":{\"email\":\"itsmyemail@mailserver.com\",\"text\":\"my email\"},\"check\":{\"checked\":\"true\"},\"date_desired\":{ \"date\" : \"2019-01-21\" }},\"status\":{\"label\":\"new\"}")
        {
            id
        }
}

I also noticed that you’ve got another status column on your board with the ID “division”. Does that status column update as expected?

Yes. Goes in fine. See below. But something about either having a second status column or perhaps having the column named as status (I tried renaming but it still doesn’t work)?

Hey Devin,

The column ID doesn’t change, so renaming the status wouldn’t do anything.

Can you double check if your brackets are matched? From your previous post, it looks like there might be a curly bracket missing at the end of your JSON string:

Do let me know!

That was it! :relieved: I can’t believe I missed that. I have been staring at this for hours.