Supported web browsers

Hi all
I’m looking to know what are the lowest version for each browser that are supported. I know that IE isn’t supported at all; are there any other browsers or versions that aren’t being supported?
Thank you!

Hey @yuvalNakav :wave:

That’s a great question! Are you asking in reference to the monday apps framework

In general, monday.com is supported by the following browsers:

Supported Versions

Make sure your browser version is at or above the following:

  • Chrome 86 and above
  • Firefox 79 and above
  • Safari 12 and above
  • Edge 86 and above

You can find more information about this below:
Supported Web Browsers

-Alex

1 Like

Hi @AlexSavchuk , Thank you very much!
You’re the best

I use Firefox 79 and everithing is fine

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.