Trouble installing monday code CLI on windows

I’m having trouble setting up my work PC for working on my Monday app. I’ve had no troubles working on it at home.

I was told that I had to get our IT company to install everything - I walked him through it as he controlled my computer remotely (the blind leading the blind).

This is Windows 11 Business.
From one of their administrator accounts he installed Node.js, which came with npm. He ran npm install -g @mondaycom/apps-cli which seemed to work fine.

I couldn’t test anything at the time as work was busy so it’s a few hours later now. I just tried running mapps init and mapps help but I get the following error:

mapps : The term 'mapps' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ mapps help
+ ~~~~~
    + CategoryInfo          : ObjectNotFound: (mapps:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

I’ve tried running powershell as administrator, I’ve ran the install again both on my normal powershell and with it running as administrator, no errors

npm install -g @mondaycom/apps-cli
changed 402 packages in 1m
94 packages are looking for funding
  run `npm fund` for details

Any ideas what I’m doing wrong?

I haven’t installed either monday SDK yet, as I was confused whether it needed to be done in the project folder or somewhere else - I’ll happily take an answer to that question also. Does mapps need them to run?

Thanks for your help!

1 Like

Hello there @TPCouriers,

Would you be able to please submit this form so our team can take a look into this?

Looking forward to hearing from you :slightly_smiling_face:



In case anyone else runs into this problem, @Matias.Monday and the team got it fixed with this solution:

It looks like the install folder is not part of the folders the system is looking for executables at.

They have suggested checking:

  1. Where the destination folder of npm install in your computer is. You can find direction here: folders | npm Docs

  2. Make sure the folder is included in system execution path (example of how to do it here: How to Add Executables to your PATH in Windows | by Kevin Berg | Medium

  3. In Windows the file might be with .js extention, so you might need to run “mapps.js”

  4. If you are not able to run it as an executable, you can run it with node:

node path/to/install/mapps(.js?)

I only needed the first 2 steps, as the npm folder contains the mapps file, and I don’t need the extension to run mapps now that I’ve added the folder to the Path variable.

1 Like

Thank you for sharing this @TPCouriers !!!

1 Like