Unable to clear dropdowns with API

I have tried every permutation of updating a column value: simple value of “”, json “{}” and “{“ids”:}”, json in a change_multiple_column_values, as well as “clear_all”: true.

The thing is most if not all of these appear to succeed - api appears to succeed (unless you also then query for the columns value in the mutation). The board in the browser shows the column being cleared - but as soon as you refresh the values come back. What is extra odd is once they come back, if I add another item in the dropdown the values that should have been deleted vanish, only to return on the next refresh.

There appears to be some sort of bug someplace?

hi @codyfrisch

Have you tried to use the same one as for clearing the people column?

value: "{\"clear\":\"all\"}"

I have tried that, as well as:

value: "{ \"clear_all\": true }"

The weird part is that as long as I dont read back the value in the mutation - it seems to clear until the browser is refreshed. If i read back the column value with the mutation query, it doesnt appear to clear.

This is striking me more and more like a bug.

@codyfrisch

This works:
.... column_values: "{\"dropdown\": {\"ids\":[-1]}}"....

I’m not completely sure it SHOULD. But it does.

Hello all!

Thank you for the question and the answers.

I am sharing this with the API team so that it can be reviewed :slightly_smiling_face:

Cheers,
Matias