Url for external app is loading twice

Hello,

since a few month we noticed a different behaviour on our custom apps, loaded from an url in item view. All custom apps are loaded twice, every time. Before it was just once, as expected.

To reproduce the issue, I’ve created a blank app and just added an url from webhook.site to observe the requests. As you can see, the app sends 2 identical requests. Sometimes one of the requests does not have the “sec-fetch-user” header, sometimes one of them does.

image

As a result it creates often confusions for the users as the app reloads after it has already been rendered.

Is that a known issue / is there a way to prevent the reload?

Thank you very much.

Regards,
Sergei

1 Like

Hello there @sleginkov,

Our team is aware of this issue and will work on a fix for it :grin:

I will update here when it is ready.

Cheers,
Matias

2 Likes

Hello again,

Matias here!

A fix is on the way and it should be deployed during next week. Would you be able to please test this again on November 2nd (Thursday) and let me know if the issue persists?

Cheers,
Matias

1 Like

Hello again,

I was informed that the fix has been deployed :grin:

2 Likes

Hi Matias,

great, thank you. It works well now! :slight_smile:

I am happy to hear that @sleginkov !!

Hi Matias,

unfortunately the issue is still not completely solved. We’ve found out that the issue still persists if an app was opened the first time after a page reload. On subsequent access it does not reload, even on different boards.

Maybe the team can look into it?

regards
Sergei

Hello again @sleginkov,

Please send all the data with a screen recording of this specific case to appsupport@monday.com and we will take a look into it!

Cheers,
Matias

1 Like