Webhooks stopped working

I have been working with a client who wants to connect dashboard with Monday.

I have successfully had webhooks working I can’t create a new one as I’m now getting this very descriptive error “Failed to communicate with URL provided.”

I uploaded a basic challenge-response script to this url:
https://dashboardonline.com.au/connect/monday.php

Which works but not through Mondays Webhooks.

Why would it work fine for 3 weeks then not work?
I suspect the dashboardonline.com.au domain is blocked by Monday.com which seems strange.
Can tech from Monday tell me why this is not working now?

EDIT: Please note I moved the script to a test server and it works fine. Can a Monday.com tech help here?

Another EDIT: I pointed another domain to the server and now it works on https://www.onapage.net/connect/monday.php.

So its to do with the dashboardonline.com.au domain.
Can anyone shed some light on that.

the challange script used is:

<?php

$data = json_decode(file_get_contents('php://input'), true);

$message = [

    "challenge" => $data["challenge"]

];

file_put_contents("response1.log", print_r(json_encode($data), true));

header('content-type: application/json');

echo json_encode($message);

?>

Hello @paulbarby and welcome to the community!

I hope you like it here :muscle:

If you are using the same script in the three different servers, then the problem doesn’t appear to lie on the script, since in two of them this works.

The most likely explanations would be:

  1. The server is not running when the webhook is triggered so it never gets the challenge back.
  2. There is a typo somewhere and you are not really reaching that endpoint.

If you check those things and still can’t find a way to make it work, please send us an email to appsupport@monday.com and we can take a closer look into it :slightly_smiling_face:

Cheers,
-Matias

I know the server is running or I would have a bunch of angrey customers on my case with in minuets.
I
I pointed another domain at the server and run the webhook setup again. This time it worked. So this proves that Monday.com is blocking the domain dashbaordonline.com.au.

What I’ve been trying to find out now is why its blocked.

Is there some blacklisting system that blocks a domain if an API call or Webhook response id malformed?

Hello again @paulbarby.

In that case, could you please send us an email to appsupport@monday.com so that we can take a closer look into this specific issue?

Please add all the information you can in the email so that our team will have a good context on why your domain is not working.

Looking forward to hearing from you :slightly_smiling_face:

Cheers,
Matias