API Response Header Parameters

Hi Gurus,

I don’t know what has been updated from monday, but from today morning, my integration using monday API started hitting error saying that “HTTP header is larger than 8192 bytes”.

It seems like it cannot handle the header more than 8KB. Anyone knows how to suppress or make monday API not returning header data? I tried in postman, and noticed that the custom parameter “content-security-policy” is quite large. Is there anyway to make API not returning this parameter?

Thanks and Regards,
Leo Li

Hello there @leo.li,

Would you be able to please fill this form adding as much information as possible to it (such as account ID, board IDs, item IDs, timestamps, etc.) so that our team can take a look into it?

we are also seeing this issue as well on our integrations. This started to happen on June 30th.

Hi Matias,

Thank you. I have submitted a ticket with that form.

Hi @YingLi,

Can you also fill out a form adding as much information as possible to it (such as account ID, board IDs, item IDs, timestamps, etc.) so that our team can take a look into it?


Sorry to be so ignorant here, but where is this being thrown?

I know this is big, but can’t you configure your system to accept headers that are larger?

In my case, we are using SAP CPI as the integration tool, and I can’t currently find an option to configure it to allow bigger on the SAP CPI side. I have a ticket open on that end as well.

We are using a cloud integration platform, so I couldn’t do anything to that. I have learned that postman increased the maximum size to 10KB, but it seems like most of the services/platforms is still having the limit at 8KB. I am also not an expert in this area, so it took me quite a long time investigating yesterday.

Hi Rachel. Just wanted to chime in to say that I am seeing the same issue. I have a custom integration that was working great until the 30th. Now I am getting an error: Header size exceeded max allowed size (8192). I am trying to increase the maximum, but it is not turning out to be easy with my toolset.

Our integrations are affected too, just to chime in. Ticket open with support since yesterday.

Hello everyone,

Our team is working on a fix that should be deployed very soon!

I will update you here as soon as that happens!

Hi Matias,

I received a reply of the request ticket from Luis Rogers, saying the fix has been released.
However, it’s still showing the same error from my side.

Hello there, as a workaround for nodejs I used:


(taken from some stackoverflow thread)

Hello there @leo.li,

Please share that with Luis so that he can continue the flow with you :smile:

Thank you @LaurentB for sharing a workaround that works for you!


I’ve gotten a reply from the SAP CPI/Integration Suite that there is nothing we can do/configure to allow for response headers greater than 8kb.

I have submitted a ticket with Monday and am working with the rep.

I have noticed that recently as of July 7th, the header response side is smaller now (around ~7kb), so the integrations on my side started to work again as of July 7th.

Hello again,

Matias here!

Our team deployed a fix for this :smile:

1 Like