Can not Delete / Remove Cards Widget from Dashboard

Hi, This one has stumped me.

Created a cards widget in a dashboard which I decided didn’t meet my needs. I cant seem to be able to delete it. When i click on the 3 dots on the right of the widget all I get is

Reporting that I am experiencing the same bug across two different monday accounts.

The options dropdown is lacking the delete option. I am on a Mac using Chrome and tried doing a full clear cache hard reset.

I just sent an email to their help team to report the bug.

Hopefully this will be an easy fix :slight_smile:

Hi@LaunchMe @Mattieuk ,

Its working in mozila firefox.please try in any other browsers.

For further implementation details kindly connect us:
MSquare Support
Visit us here
Youtube Channel

@MsquareAutomation @LaunchMe

Thanks for the reply. I have tried Safari, Chrome, Firefox and Edge browsers. The result is the same unable to delete Cards widget from dashboard.

Hello @Mattieuk !

If the issue persists, I would suggest opening a ticket with monday support to let them know.

Giannis, Implementation Consultant at

Ticket Raised and not the response I was hoping for:

For info

I understand the importance of being able to remove the Card Widget. I’d be happy to continue assisting you so we can solve this as soon as possible.

Our developer team confirmed this is the new expected behavior for the cards widget. This is because there have been some updates on the Cards widget, now added in standalone mode. This means if you added it to the blank view and there are no other widgets, it will be added without the option to undock it. If it is added to a blank view and other widgets are added first, you can add and resize it and put it where needed. However, it won’t have the option to be deleted, and if you delete the other widgets, it will automatically transform into a standalone view.

In this case, I recommend deleting this dashboard and creating a new one since the cards widget needs to be removed. I’m very sorry for the inconvenience this might cause.

Wow, very interesting to know! Thanks so much for sharing!