DOMO API stopped working on Monday

I built an API with the DOMO developers studio and it worked great, bringing in Monday boards, items, etc into DOMO. On Labor Day, it stopped working with the error that I had an invalid API Token. So, I generated a new one in Monday Admin, but I get the same error. I cannot connect to Monday. I reached out to DOMO and they have the same problem - their API will not connect.
How can I fix this? Has anybody seen this problem before?

Hey John, this is really strange. We are not seeing any widespread issues with API tokens, so I suspect this issue is cropping up based on your implementation.

Can you tell me more about how you’ve got this connection set up? Did you build the logic for your API calls in DOMO or are you using a pre-built connector?

I created this connector for DOMO using their Connector Builder (https://api.domo.com/builder/index.html#!/).
We have been using it since December 2019. It first failed on Monday Sept 7, 2020.
The authentication looks like this:
var encodedData = DOMO.b64EncodeUnicode(metadata.account.username + ‘:’ + metadata.account.password);
*httprequest.addHeader(“User-Agent”,“USCCA GraphQL Client”); *
httprequest.addHeader(“Authorization”,“XXXXXX”);
var res = httprequest.get(‘https://uscca.monday.com/v2/’);

Hi @john.watson

There is definitively something broken at the monday site. See also: App framework input trigger stopped working

Earlier today triggers (webhooks) did not fire and later they fired with a 10 minute delay. Support team is working on it as I understand.

Thanks for that information. I was also working with the ‘Third Party Connector’ team @ DOMO. They tried to use the same API Token I have and connect to our Monday instance. They received the same error message.

Daniel here :wave: Thanks for letting us know - we’re investigating this on our end. I appreciate everyone being so responsive, I know it can be frustrating.

@john.watson Reading the error I suspect this may be tied to your account - having spoken with the team I’m going to reach out personally over email. I’ll post back here once this has been resolved in case anyone else runs into this issue in the future.

@basdebruin I think there might be some confusion given a few errors occurred around the same time. The automations not firing / being delayed was a platform issue we experienced a few days ago, this has since been fixed. The remaining issue is with editing the app recipes, which is being investigated by our developers. The apps platform itself however is not down.

Hey all - this has been resolved!!

As a note for anyone in the future who might be stumbling onto this thread - it looks like we’ve discontinued the use of the ‘slug+monday.com/v2’ URL for querying the API. This was a bit of an obscure undocumented feature we had when we first launched the API.

Moving forward - you’ll want to make sure your queries are being pointed at our API address:

https://api.monday.com/v2/

-Daniel