App framework input trigger stopped working

Hi there :wave:t2:
Since today, the “Create Item Trigger” stopped working.
One of our app is using it, and it does not send any data anymore.
When I try to access the input trigger in the app framework, here is the result: https://youtu.be/0b33_H8cVmY
It was running very well this morning, we didn’t touch anything on our side.
Any help is welcome…

I just checked with other recipes: the problem happens to any kind of input trigger.
Even when I’m trying to create a new recipe, I get an error.

[EDIT]: we received data, but with after very long delay

I got an answer from the support. The fix is ongoing.

Hi @jeromeskiply

Did support give you a time frame for resolution? I experienced the same with all my apps, including the production ons where people paid money for. Moreover the monday status page says “All systems up”.

1 Like

Hi @basdebruin,
No resolution time frame for the moment…
They say there are downtimes in relation with the automation system.

@basdebruin the automation issue seems to be solved (https://twitter.com/mondaydotstatus/status/1303713018350501890), but I still can’t edit an input trigger (my first video link).

@jeromeskiply

Exactly the same here. Triggers work again, but I can’t edit the recipe in an app that contains a custom trigger

Hey @jeromeskiply & @basdebruin,

The automation issue should now be resolved - please let us know if you’re still seeing it occur.

As for the issues with the apps (in particular editing the recipe) - I’ve gone ahead and pinged the dev team on this. More to come as we hear back.

-Daniel

Hey @dsilva,
Any update?

Hey @jeromeskiply

The issue with the automation should be resolved - let me know if you’re still running into it.

As for the issues with the apps - our dev team is looking into it right now, hoping to have some news for you soon. I’ll post again on here as soon as I know more / we have a fix.

For the time being however please know that apps are still working as expected on existing accounts - the only issue at the moment would be for editing the recipes on these custom actions / apps.

-Daniel

A fix was deployed for editing the triggers, please let us know if something is still not working.

Hi @edogr1,
Same problem. The fix didn’t fix the error on my side. And you @basdebruin?

@jeromeskiply, can you please attach a screenshot of the developers tools console?

Hi @jeromeskiply

Same here, the triggers are fired, but you can’t edit a recipe (at least not a recipe that contains custom triggers). The latest I got from @dsilva (by email) was:

We don’t quite have an ETA right now - however please know we’ve passed the information over to our developers to look into.

I will mention that the existing issue right now is related to editing existing recipes, not the entire apps frameworks. This means that the existing apps and existing recipes installed on accounts will continue to work as usual. I’ll be sure to let you know as soon as we have more information on this.

Hi @edogr1, hi @dsilva,
I have the same error for a Monday.com native automation.
See the video here: https://www.youtube.com/watch?v=kRkgZsxoxkk&feature=youtu.be
I put the error message in console at the end.
What’s wrong?

Hi @jeromeskiply

Your console log looks very much the same than mine, let’s hope this get resolved quickly.

Hi @basdebruin @jeromeskiply, we deployed another fix, can you please take another look?

1 Like

Hi @edogr1,

I have just checked and after logout / login it seems to be fine now. Many thanks for your support on this one.

Hi @edogr1
It works! Thanks!