ERROR "No Query String Present" - When I try to Create Workspace Mutation with Zapier

Hola. I am trying to establish a Zap that Creates a Workspace using the mutation of:

mutation {
create_workspace(name: “New Workspace”, kind: open, description: “My New Workspace description”) {

This works using the developers code just fine, but I keep running into a brick-wall when I try to Create the Workspace using Zapier.

I have tried a series of configurations and keep getting the same error.
Is there someone that could share the string with me that I should be adding? Please…and thank you.

I have attached a snippet of the Zap too.

Hi @corey.masson!

I think you just need to alter your query syntax. Do you mind giving this a try and letting me know if it works for you?

{“query” : "mutation { create_workspace (name: \ "New Workspace\ ", kind: open, description : \ "My new workspace description\ “) { id } }”}

You should also include a header for content-type of JSON!


Hi, I was able to get the hook to work by performing a POST as seen below. Cheers.

I’m so glad to hear!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.