Monday SDK storage service not working

There seems to be an issue when I make calls to delete and update values in a board’s stored values.

These are what my calls look like:
await this.monday.storage.instance.deleteItem('key');
await this.monday.storage.instance.setItem('key', newVal);

The set item works fine on the first one, but after that it doesn’t update the values.
Delete item never worked. I even tried setting a value to null, but didn’t work.

Can someone help me figure this out?

Hey @amit.lzkpa

That’s a bit odd - I’d love to help you out with this. While we’re troubleshooting on our end, would you mind helping us out with some questions?

  • Would you be able to send us an example of the code/query that is causing this behavior?
  • Is this the first time the issue has occurred? If not, when did it start happening?
  • Is this happening only on one app, or all of them?
  • Similarly is this happening on one specific instance on a board, or is it more broad / widespread?

Looking forward to hearing back from you!

-Danny

I can comment from my own experience here.
DeleteItem never has worked (no errors).
SetItem only accepts/acts on truthy values, falsy values are ignored.

My workaround has been to set to ’ ’ (with one or more spaces) to delete.

2 Likes

It seems to be working for me now.
Not sure if any fix was patched in the interim.
Would be happy to provide a detailed sample if still needed. Let me know!

Hey @amit.lzkpa

Understood. Can you let us know if you run into this again? We’ll take a look.

-Danny