Need help with "Unsupported query" for GQL /v2/file upload

I’m trying to upload files from an IOS app I am making.
No matter how I approach the GQL POST to /v2/file upload, I get 400 “Unsupported query”.

When researching this issue I found this other community post which resolved the issue by updating their postman.

So following that lead I have tried making the gql request using 3 different frameworks:

  • using apollo-ios graphql client
  • manually building the gql request using urlsession
  • manually building the gql request using alamo fire.

For all of those approaches everyone has the same result of 400 “Unsupported query”.

Are there any ways for me to get more debug information on this error, so that I can get a more specific idea of what I need to address? Any help with debugging or exploring this problem would be greatly appreciated!

Hello @dake and welcome to the community!

I hope you like it here :muscle:

Could you please send us an email to with all the information you can about the issue so that we can take a closer look and give this some following?

Looking forward to hearing from you :slightly_smiling_face:


Thanks @Matias.Monday I’ve reached out, and will respond back here if I find anything out.

1 Like

Unfortunately there has been no response so far.
@Matias.Monday do you know if there is anyone else I could reach out to?

The app is hard stuck until I can figure out what is wrong with the graphql file uploads :frowning:

Hello @dake !

From which email address did you send the email?

Just to be safe this is my ticket # from the message:
ticket id:#2036169

Hello there!

Someone from the team will reply soon :slightly_smiling_face: