Quickstart integration: uncaught syntax error

Hi everyone,

I’ve been using monday.com for a year or so and would now like to learn how to add new features by writing apps. I’m a total coding novice beyond some Excel VBA.

So I’m trying to follow the Quickstart Guide for integration recipes.

I’m stuck at this step: “…run the command scaffold in your command line, and paste the resulting URL into the URL box.”

This is what I’m doing:

  1. Copying the command

  2. Pasting into node.js and hitting Enter

  3. Resulting in ‘Uncaught SyntaxError’.

I’m sure it’s something super basic I’m doing wrong, please can someone give me a pointer?

@Megan

My warmest welcome to the community! Thanks for checking in with us here.

The app install command is not actually to be used within a Node environment, but is rather to be used within the terminal app.

It seems like your environment might not be set up for terminal commands, or you might just need to use the Terminal instead of putting the command in NodeJS. I’ve just tried to install this on my end, and had no issues, so I’m wondring if we can take a couple of steps to troubleshoot this further. Here’s what I would recommend testing:

Check if you have:

  • Homebrew - package manager for MacOS
  • NodeJS - server-side Javascript framework
  • NPM - package manager for node

Homebrew is a command-line package manager that lets you install (and update) programs on your Mac with minimum fuss. Here’s the homepage.

To do this, open the terminal app, paste the following code, and hit run:

/bin/bash  -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"

You can also run the following commands to check the version of each app above:

node -v
npm -v
ngrok -v

I hope this helps. Let me know if this does the trick for you.

-Alex

Hi Alex, thanks for your reply and sorry for the slow response, I’ve been on holiday.

I’m actually on Windows, not Mac, and also tried running the command from the Command Prompt which also resulted in an error:

I have Node and NPM installed:
image

Any help is really very much appreciated!

@Megan

Got it, thanks so much for clarifying!

In that case, you might need to simply download the code package from GitHub directly, and not via the command. Could you please try following the guide on troubleshooting errors for our quickstart guides on Windows?
Windows Quickstart Integration Troubleshooting

This should do the trick for you.

-Alex