Scaffolding process for item view does not return a URL

Hi all,

I am just starting to explore development of Monday apps and found a problem.

Following the steps described in, I have created an “item view” feature. In step “Start from a template” I chose template “Quickstart - ReactJS” and go to “Set up your dev environment”. Then I copy the OS command displayed there and run it on my shell (zsh on MacOS). The problem is that this process running on zsh is stuck after issuing message “Running the project” and it never produces a URL that I can paste into the page on This is the full process output:

xxxxxxxx@yyyyyyy % npx @mondaydotcomorg/monday-cli scaffold run ./ quickstart-react
> Starting scaffolding process
> Repository was downloaded successfully
> Copying the directory
> Installing packages. It can take a few moments
> Node modules were installed successfully
> Running the project

As an alternative, I also tried to follow instructions at the file of the downloaded code, using npm start. This failed also, as I tried connecting to http://localhost:4040/status and an error was returned.

A few days before, I had run the same process for an integration and everything worked fine.

Thanks in advance!

Hello @pmaranon!

This looks like it is not related to the command itself since I tested it and it is working for me. It looks like it could be an issue related to your environment.

I could tell you some ideas I would look into to troubleshoot. It is important to say that this is not an official recommendation from Monday since it is not related to our platform, and I can not assure a satisfactory result by doing this. They are just ideas on where to look for the answer:

Killing all terminals and then:

  • Running the terminal as an administrator and trying
  • Trying using the super user commands for Windows, Mac or Linux

I could also find this post which is old, but may have some information that could help.

I hope you find the answer to this and I hope this documentation / posts help!


Hi Matias,

As I am working on MacOS, I have tried running the commands with sudo and killing terminals and their windows. I also tried rebooting the laptop and retrying. Unfortunately, these measures did not make any difference.
I have not been able to understand how the linked post may be relevant to this case.

Pepe Marañon

Just in case somebody else finds this question, the problem turned out to be with ngrok, as ngrok did not start correctly when invoked from the npm process.
There are two possible workarounds. First one would be to start ngrok from the command line after the local server was started by npm. The other workaround would be to use directly the localhost URL served by the local process, as explained in this question about the same problem.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.