App BaseUrl with port #

Hi,

I need to use a URL for the App BaseUrl that includes a port # (ex: https://www.example.com:3000). It doesn’t seem to be working, and I’m wondering if this is actually possible on Monday. Thanks.

Hi @Msh!

Hmm no I don’t believe that including the port # should be affecting the efficacy of your URL.

I’m curious to learn more about how it isn’t working. Is your URL just not receiving/sending any data? What are you seeing on your end?

It would be super helpful to see a visual of what you have so far.

Thanks!

Hi,

It’s behaving just like I put a nonexistent URL into the BaseUrl field. I see my program calling the Recipe URL, but it just hangs after that, no data returned, until the program decides it’s just not getting any data and completes as it is.

Here’s the screenshots. When the URL is good, there should be a whole lot of data being shown between the mondayWebhookUrl and the “return outputFile” step (ignore any other errors you see on the rest of that terminal screen).

Thanks for your help.

image

image

I should add that it works fine when I set up ngrok forwarding that includes the port in the full forwarding address (i.e. “./ngrok http https://localhost:8304”), but for other reasons I’m not able to use a service such as this.

@Msh

Thank you for following up with us here and providing further detail! That really helps.

Just to make sure we’re on the same page here, is the URL you are currently trying to use a publicly accessible URL? The monday.com server will need to be able to reach your endpoint, and if you are using your machine’s IP address, that will likely not work as expected.

Are you able to use a service like localtunnel, for example? Considering the NGROK URL works once you enter it, I’m wondering if this is an issue related to the server accessibility, rather than the port being included in the URL.

I’m looking forward to hearing from you soon! :slight_smile:

-Alex

Hi Alex,

Yes, the URL is publicly accessible. I’m able to reach a nodeJS server running on the machine using the same ip:port configuration. And everything works fine on Monday using NGROK, with a single URL instead of a URL:port combination. I’ve tried using the URL equivalent to the IP address given by Amazon (my test server is on EC2, so I’ve ruled out the idea for myself that it’s an issue with it being a problem using ip address vs. named URL). I’ve never heard of localtunnel, I can look at that, but I don’t think I’ll be able to use that in the end unfortunately. It’s just that everything seems to stop for me once I try to put a port # into the BaseURL field, so that’s why I’m looking at this.

Thanks,

Moshe

Hi @Msh!

At this time, we want to go ahead and look at what may be the causing the issue for you.

As such, do you mind letting me know the URL of your account, as well as a precise timeframe (with the timezone) of when you tried to set up this server? This way we can better investigate our logs.

It would also help to get the URL of your app with the port number that you’re trying to send.

Thanks!

Hi,

Is there a way of sending you the URL names and other info without having them posted on the board?

Hi @Msh, absolutely!

Feel free to email all of the requested information above to our appsupport@monday.com email.

We can take a look then!