Creating an item with columns populated

I’m utilising Postman to create a new item with populated columns, however I’ve hit a problem where the item is created, but the fields remain blank.

This is my syntax

mutation {
create_item (
board_id: 283592949,
group_id: “For Consideration”,
item_name: “New Suggestion”,
column_values:"
{
\“Priority\” : {\“label\” : \“Low\”},
\“Your_Name\”:\“Hello world\”,
\“Department\” :\“Hello world\”
}"
) {
id
}
}

If I try

mutation {
create_item (
board_id: 283592949,
group_id: “For Consideration”,
item_name: “New Suggestion”,
column_values:"
{
\“text\”:\“Hello world\”,
\“text\” :\“Hello world2\”
}"
) {
id
}
}

Then the left most text field is populated with “Hello world2”

GraphQL is new to me, so I’m sure I’m missing something obvious, but after going through the examples on here and the documentation I’m no closer to getting this to work.

Any help you can offer is greatly appreciated.

Quite typically, as soon as I posted this, I found the solution on another post.

https://community.monday.com/t/still-having-issues-with-column-values-within-create-item/1594

For anyone who comes across this in future, the friendly name does not work, you need to identify the column by the columnid name. I still had some trouble with the status, but changed it to index instead. Follow the link above on how to get the ids

mutation {
create_item (
board_id: 283592949,
group_id: “For Consideration”,
item_name: “New Suggestion”,
column_values:
“{
\“status79\”:{\“index\”: 0},
\“text\”:\“Hello world\”,
\“text59\” :\“Hello world2\”,
\“email\” :{\“email\”:\“test@test.com\”,\“text\”:\“test@test.com\”}
}”
) {
id
}
}

This was very timely, I’m trying to do the exact same thing. I’m getting a “200”, ok with the requested data returned, but the columns are still not getting set. I’m using variables in my query. Can anyone see why it’s not setting column values? As pointed out, I’m using the column IDs, not the names.

mutation ($board: Int!, $group: String!, $name: String!, $column: JSON) {
create_item( board_id: $board, group_id: $group, item_name: $name, column_values: $column) {
id
column_values {
id
value
}
}
}
{“board”: nnnnnn,
“group”: “topics”,
“name”: “The Name”,
“column”:
“{ \“text\”: {\“start_time\”: \“Now\”} }”
}

And the result:

“data”: {
“create_item”: {
“id”: “nnnnnnn”,
“column_values”: [
{
“id”: “start_time”,
“value”: null
},

(Edited, noticed the backslashes didn’t show, had to double up on them). Not sure why preformatted text is not working in this forum. Anyone?

I found the issue. I was assuming that the type needed to be specified in the column_values, but it does not. Removing “text” above solved the problem.