Groups not showing in dashboarda

I’m able to add a group to a board. When I go to a dashboard and try to add that group to the table settings I see it and I can check it off, but its not showing up in the displayed table. If I uncheck an existing group on the dashboard it disappears and then reappears when I check it again. What am I missing?

Hey Mike! If you try duplicating this table widget or the entire Dashboard and then try selecting the group again, does it appear now? Or is it still not showing up?

If it’s still not showing up, perhaps there is a permissions issue? Are there permissions set up on the original board this group is from that the people on the Dashboard would not have access to the original board? If someone on the Dashboard does not have access to a board linked to the Dashboard, the info from that board will not show up in the Dashboard.

Let us know and we’ll figure it out together! :blush:

Thanks Charlotte. Recreating the dashboard works, but when I test creating a new group and adding that to the dashboard its a no-go again. I don’t want to have re-create a dashboard every time I add a new group to an existing board. thanks