Integromat - GraphqlCustomExceptions::CorrectedValueException has occurred during simple column conversion - Revival

Hey all, I had bunch of travel happen and when I got back I saw my original post had automatically been closed. I hope that reviving this isn’t against the rules:

Since then, I have tested a couple things, first I attempted to use Person column JSON as mentioned by Helen, but I received the same error:

Then I created an actual People column to test on and tried both versions of the JSON and again received the same error.

It doesn’t seem to matter which column or which format I use, it’s the same error.

I’m attempting to make a sync with an outside system that only updates certain columns by specific criteria, and the People column array is pulled out of monday itself first, so I’m really frustrated that I can’t plug and play this.

Any solution?

Hey @Enyetahip :wave:

Thank you for following up on this! Let’s continue sorting this out.

That is indeed quite odd! Since the error mentions attempting a simple value conversion, this means the platform expects a string with the IDs of the users to assign, for example:


You will also need to make sure that this string is escpaed as JSON within the array. Perhaps that was causing the issue earlier. Having said that, this does seem quite peculiar and I’m wondering if this has anything to do with the array formatting here.

It would really help if you could send a screenshot of the actual values being sent by Integromat so that we could take a closer look. I understand this might contain sensitive data - but if you could blur out the actual data being sent, and just leave the formatting for us to see, that would be really helpful.

I’m looking forward to hearing from you soon! :slight_smile:


This here is an example of what the data is displaying as (To be clear: I’ve been hardcoding the JSON and information for testing, what I’d really like is to just pull the array out of an existing column and shoving it back into another)

This is the input JSON directly:

I mean, I am custom creating the structure for monday with a JSON creation step using the API documentation -

and then just feeding it that array -

Text, Phone, Date, all those basic columns seem to work like this just fine.

The original post has a lot of screenshots as well, and a more basic descriptor of what I’m trying to do


Thank you for circling back with me! I did review the original post before making my initial comment.

Based on the info you’ve just showed, it seems like you should be able to remove the “id” part from your values and it should work as a Simple column value.

Instead of:

{“id”: 20215664}

Can you try inputting:


This should do the trick, from what it looks like.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.