Item Copy function - removing the added " (copy)"


I have a couple of questions regarding the item copy function from within a group.

  1. When I duplicate a line item the new line item appears as:

abcd1234 copies to
abcd1234 (copy)

If I copy again it becomes

abcd1234 (copy) (copy)

That make sense, but is there a way to copy a line item so that the (copy) doesn’t appear? I manually go back in and delete it, but when I have a volume of these (sometimes 20 or 30 line items) it becomes tedious.

  1. Is there a way to duplicate one line item a number of times, without doing it one at a time? I have instances where I need to show the same line data many times.

Thanks in advance

I have used an Integromat integration to remove the FW: at the front of the item name when forwarding emails to a board. You could do the same type of thing with the (copy).

Thanks for your reply Jim, I will take a look at this.

As far as I know: when you use the duplication function in the UI you will always get the (copy) extended to the name. You can however setup an Integromat watch or a webhook that looks for (copy) in the name and remove it.

Hey Jim! Do you mind sharing your Integromat integration set up? I just created an account there and have been trying to figure it out on my own with no luck!


It’s pretty straightforward to do…

In Integromat, create a scenario:

  1. Module 1: Webhook
  2. Module 2: Update Column Values of a Specific Item (monday module)
  3. Add filter between 1 & 2:

Once this has been created, it can be added to any board without additional modification…

In monday, add an integration:

The exact string in the replace function is:

{{replace(3.event.pulseName; "/(.*) \(copy\)/"; "$1")}}

Hm…I’m not able to see “3. event: boardId” as a variable/option. I wrote this in on my own and it didn’t run correctly.

I set up the webhook and am in dev mode on Monday. Did you initially have trouble seeing that option?


the "3. " portion is referring to the previous webhook module. For you it is probably "1. "

When you are editing, just pick the corresponding field from the webhooks module. For the Board ID, make sure that you turn on the “Map” button first. (the blue toggle from my screen shot)

Hi @AS9409 and @jenstratton :wave:

Both @basdebruin and @JCorrell are correct - currently the (copy) text will always be added to the item when it is duplicated within the platform.
As they’ve both suggested, using Integromat / Webhooks would be a great workaround for this.

With this in mind, it does look like this post Item Copy function - removing the added " (copy)" - #6 by JCorrell might have solved your question.
If so, it would be great if you could mark this as the solution - it really helps our other users in the Community!

If you have any additional questions on this, please feel free to add them to this thread and we’ll be happy to continue to assist :grinning_face_with_smiling_eyes:



1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.