Permission Denied! Your token doesn't grant access to boards:read

Hi @dipro-monday.com,

I’m developing a monday app for my company to import data into a board.
I finished my first version and uploaded a build of the app and installed it so other people in my company can use it.
But I’m running in to a problem…

The app queries the graphql api using the following query:
query getBoard($boardIds:[Int], $columnIds:[String]){
boards(ids: $boardIds) {
name id description board_kind
items {
id name
column_values(ids:$columnIds) {
id text value additional_info
}
}
}
}
And this query works fine when I use the app (I’m an admin) BUT if a user runs this, the API returns the following error: “Permission Denied! Your token doesn’t grant access to boards:read”

The app is installed as view, so authentication is managed automatically
The user running the query is owner of the board the app is running on, so no restrictions there.
The app also has permissions set to “board:read”

Is there anything else I should set?

I tried to reproduce the issue with the monday example app and the example app had no errors calling the api…
Then I created a new app, with read/write access and re-uploaded my earlier app build to this instance, and now it just works!

Don’t know what caused the original problem, but at least it is solved :slight_smile:

1 Like

Hey @JeroenV ,

sounds interesting.
If you find out why that happend, I’d love to hear about it.