Query Does Not Work Past Couple Hundred Items!

I’m getting an error when running a query. The query works for 500 items, but when I jump up to 1000 items it seems to be giving some kind of error. I ran a complexity query just to be sure I wasn’t reaching any API limitations and it doesn’t appear that I am. I’m really not sure what is going on here. Please Help!


It spits out this error sometimes. My board has 2800 items on it. The complexity when I query 100 items is 1420 and returns results. But when I up the limit to around 500 it gives me this error. I’ve tried this in the api playground as well as a custom written python script and both return the same error. I kept thinking my query was wrong, so I went to the playground but got the same problem.

  "message": "Unexpected token u in JSON at position 0",
  "stack": "SyntaxError: Unexpected token u in JSON at position 0"


I just ran 200 item limit and got this result for complexity. If this is for 200 items, how is 500 even close to the API limitations???

1 Like

I am getting the same error!

Hello @galmog and @christian.lee !

I do not think this is related to the complexity limit.

Having said that, I could not reproduce the issue myself.

Would you be able to send us an email to appsupport@monday.com with a screen recording of the issue so that we can take a look into it and give it some following?

Looking forward to hearing from you :slightly_smiling_face:


It seems that for me the error occurs when I have in the query:

column_values {id value text}

but when I remove the text to have only:

column_values {id value}

It works…(without the column text of course).
As well, if I limit the query to 100 it runs as well regardless…

1 Like

Hello @Matias.Monday
Just emailed a screen recording over. I tried to click around the developer tools too to see if you guys needed any information from there.

Interesting that someone else was able to reproduce the issue. I thought I was going to go crazy yesterday trying to make my query work. For a while I thought I was writting the query wrong, but realized that it was only happening after querying about 500 items or so.

Yes, I noticed that as well. I wish I could do without the text query, but some columns do not have all the information you need in just the column values unfortunately. I’m glad I am not alone here. Hopefully it is just a simple bug in the API that can be easily resolved.

Hello @christian.lee and @galmog

I believe the issue here is a timeout error. When the server takes more than 60 seconds to retrieve information, it stops and shows that error message.

This is why it works for fewer items. Because the amount of data being retrieved is smaller.

You might notice that getting rid of the “text” field might make it work, but that is because in that case, you would be retrieving less data.

I think if you keep the “text” field and lower the limit to 50 (for example), it will work, and that would confirm my suspicion.

In this case you can use pagination in order to avoid the issue.


1 Like