Quickstart-react fails - Connection refused: tunnel.monday.app:43279 (check your firewall settings)

Hello,

I’m trying to set up my development environment. I am running the quickstart-react following the documentation but I am getting this error:

ERROR: got remote connection error connect ECONNREFUSED 34.171.76.64:43279 {"tunnelId":"e00da7"}
ERROR: e00da7 connection refused: tunnel.monday.app:43279 (check your firewall settings)
err: {
[1]       "type": "Error",
[1]       "message": "e00da7 connection refused: tunnel.monday.app:43279 (check your firewall settings)",
[1]       "stack":
[1]           Error: e00da7 connection refused: tunnel.monday.app:43279 (check your firewall settings)
[1]               at Socket.<anonymous> (C:\Development\quickstartreact\node_modules\@mondaydotcomorg\tunnel\src\lib\TunnelCluster.js:93:38)
[1]               at Socket.emit (node:events:513:28)
[1]               at emitErrorNT (node:internal/streams/destroy:151:8)
[1]               at emitErrorCloseNT (node:internal/streams/destroy:116:3)
[1]               at process.processTicksAndRejections (node:internal/process/task_queues:82:21)
[1]     }

Before the error I get this message:

INFO: your url is: https://envious-ibex-90.tunnel.monday.app

After the errors I see that the app compiles successfully and I can access it locally. I can see the page in the browser

[0] Compiled successfully!
[0]
[0] You can now view monday-integration-quickstart-app in the browser.
[0]
[0]   Local:            http://localhost:8301
[0]   On Your Network:  http://X.X.X.X:8301

However, the public URL, which I need to link it to the app in the Monday.com website, does not work. I get a 404.

I am not using a VPN.
I’m using windows.

Can you please point to what I need to do to solve this problem?

Thanks

Hello @kmora and welcome to the community!

I hope you like it here :muscle:

This looks like an error in your own environment and not on monday’s quickstart project.

From the message you get: “message”: “e00da7 connection refused: tunnel.monday.app:43279 (check your firewall settings)” it looks like you might have a firewall blocking this in some way.

Could you please check your firewall?

I hope that helps!

Cheers,
Matias