Tokens are not authenticating

Wondering if API or token generation is healthy? Receiving “Not Authenticated” message in Postman with simple queries. Have refreshed my token several times and tried each. No token will authenticate. Am using

Hey there @deceiver08 :wave:

Thanks for reaching out! That definitely sounds odd. Just to make sure we’re on the same page here, are you sending your request as a POST, and is the body formatted as JSON? I would also love to take a look at how you’re sending your API token to authenticate in Postman, some screenshots would be really helpful to understand the way this is set up on your end.


Hi @AlexSavchuk. Yes it is POST. I tried sporadically throughout the day yesterday and got nothing. For the heck of it, I just submitted this morning and went through fine! I changed literally nothing. Very weird!

How long do tokens last before they expire?


That’s really odd, but I’m glad to hear that it seems to be working well now! As far as I know, API v2 tokens will be active as long as you don’t revoke the token on your end in the Monday UI’s Admin section, like so:

I hope that helps!


I am having this same issue this morning. I even regenerated my token and still does not work.

Hey @mmihalik :wave:

I’m sorry to hear you are having a similar experience here - would you mind reaching out to us at so that we can troubleshoot this further? I’d love to get a bit more information from you so that we can investigate more closely - screenshots of the way this is set up on your end and the results you are currently getting would be great.