Zapier API Key Authentication Error

I am attempting to build an integration between Zapier and Monday using the API Key for authorisation.

I have got as far as setting up the integration in Zapier and sending the api key in the header, and the request in the body.

Every time I test the integration I am required to reconnect the Monday app and enter the api key again. The result is always

Invalid Authentication ID

However Monday does process the request and return the results in the http response.

The integration cannot work if the key has to be entered every time it needs to run

Any clues as to what setting I have wrong? Screenshots included.

Hey there @Commissionly :wave:

This does certainly look quite odd! I am really sorry for the inconvenience. Let’s try and get to the bottom fo this together :slight_smile:

Just to clarify, could you please shed a bit more light on the API key you are using? As you might already be aware, we are going to deprecate the V1 API Key in the future, so perhaps that is the reason you are having this issue - it’s just not the right key?

Also, it seems like API key might be expired, at least based on the screenshots you’ve provided:

If you try to follow the link that Zapier suggests to reconnect the account, does that help at all?

I’m looking forward to hearing from you soon! :slight_smile:


Hi Alex
I solved the problem but it may point to an issue.

To solve the issue I created a new account for monday in zapier with the same api key and it worked first time. It does not explain why I was able to retrive data from Monday on the previous account even though it threw up the autentication error.


1 Like

@Commissionly wow, that sounds quite like an oddball there.

I was wondering if this is something you would be able to check in about with Zepier’s support team as well, as I think the issue might have been on their side. I am saying that because you have received and parsed data into without issues it seems, so I think they might be able to shed a bit more light on what’s going on behind the scenes here.

Either way, I am very happy to hear that you’ve been able to find a solution to this behavior that seems to have resolved the issue :slight_smile: