Email parsing to zapier to Monday

I have specific emails that I need uploaded in Monday. I currently use parsuer to be able to grab the data but with the API V2 out found out Zapier parser can do the same thing.
I’m trying to get zapier to work with the new API but can only grab 1 bit of information.
the items I need to be imported into monday are
-a hyperlink provided in the email

What I am doing wrong in the code for it to keep giving me an error message?

1 Like

Hey there @Annieo :wave:

That’s a great workflow and I’m glad you’ve discovered Zapier could help out with this!

The reason you are getting the error in this particular case seems to be related to the way you are formatting your data in the Link column. It seems like the JSON formatting is a bit off there, which is why the platform doesn’t accept the data.

You can find more information on this here:

Here is an example of JSON formatting that should go through without issues from the article:

Link Column - {“url”: “”, “text”: “go to monday!”}

I hope this helps you find the solution :slight_smile:


I’m typing it out exactly as it is being written here including all the characters (brackets, colons, quotation marks, no spaces between the characters, etc.) and still receive the same error message.
Am I over thinking this or adding information that isn’t necessary?
The url I am trying to paste is a long one, could that be the issue?

Hey @Annieo ,

could you share another screenshot?


1 Like

@TMNXT-Dev Here you go

I have had trouble with this also. The zapier JSON can be very fiddly with a lot of trial and error.

That looks right to me as a no coder.

1 issue that I had when I was convinced it was right. I was copy and pasting then editing sections from the monday documentation and community forums and it turns out the font was having an effect. This was easier to see when pasting into a word doc for later use. Specifically the “” symbols.

In 1 font style the were little (66 and 99) the other was just uniform little dashes the same on both ends.

Long story short, try typing it in manually rather than copy and paste from somewhere else.

Also confirm the column ID is infact link2 and not link_2 or link 2.

Hope this helps someone in future.




Hey there @Annieo

Thank you for providing the screenshot here! I do think @Elliot has a very good point regarding the quote symbols in your formatting - the platform would only accept uniform quotes (“URL”, for example, and not “URL”). Could you please try that out and let me know if this works?

@Elliot thank you so much for sharing your insight and experience here, I appreciate your effort to help others in the community :slight_smile:


Ok so it worked when I manually entered all the symbols and the sample text {“url”: “”, “text”: “go to monday!”}.
When I change the url to the parsed url I actually want it to bring over I get the error code again.
Any ideas of why it doesn’t like the actual URL I need to have?

Hey @Annieo ,

I’m trying to understand what’s happening on your side. :slight_smile:
What do you mean by “parsed” url ?
Maybe that’s the issue. It could be an invalid URL.

We have an email (gmail) that we are trying to load in certain aspects into a Monday board. We are using email parser by Zapier to grab the data we want and direct Zapier to load it into Monday.
The link is unique in each email and for right now the work around we are doing and it’s working successfully is to load the link into a regular text column. By using a text column it will create the hyperlink that is clickable within our monday board.
I’m really curious why it is when we actually try to use the link column type we get the error message at the beginning of this thread.

Hey @Annieo ,

I tried to reproduce your issue and it appears, when I copy your input, that the quotation marks are indeed wrongly formated. Try to retype them.

Another issue which I saw in you first screenshot is, that you actually have two URLs as a value.

Could you retry and tell me if that helped.