Zapier + Monday Integration JSON formatting issues


I’m currently setting up a meeting database and using zapier to link data between Calendly and monday. I’ve been playing around with a zap on Zapier and made some progress after reading the Json formatting page. However I’ve run into some issues with a couple columns that I’m having difficulty linking properly.
I can’t seem to get the phone column and Date + time working as I get the error (invalid value, please check our API documentation for the correct data) with every variation of the structure I can think off. Date and time seems to have an issue as the data pulled from calendly is a combination of Date and time and the Json seems to ask for them split for the format which I’m not sure how to do. For phone I’m not really sure as it seems like it should work with the current set up. It could also be an issue on Calendly’s end where the data sent is packaged in a way where its hard to use in JSON, I’m not too sure.
I’m quite new to this so I am probably missing something, any help would be hugely appreciated.
My current solution is to just put the info into a text column but I would love to be able to put the data into the dynamic columns (eg a clickable email link)

Attached below is some screenshots for context
Thanks for your time


Hi @CSanchez, welcome to our community!

Ahh yes formatting for our Phone and Date columns can be rather tricky. I believe that you may be running into trouble here because of the formatting of the incoming data that you’re using.

I would also recommend including only one or the other (phone and date) at a time. This way, you can isolate the issue and make sure that only one (or perhaps both) are experiencing an issue.

Some tips based off of the screenshot that you provided:

  • For the phone column, make sure that you’re sending the phone in the format specified here: Phone Column without Country Flag - {“phone”: “5555555555”}. The difference here is that it looks like the phone number you’re sending includes both the country code, as well as a “+” before it. These will need to be removed. If you would like to add a country code, you will need to utilize a flag instead, like in this example: Phone Column with Country Flag - {“phone”: “5555555555”, “countryShortName”: “US”}

  • For the date column, I see that you’ve actually included two dates, one that you’ve written out by hand, and the other using incoming data. In this case, you should utilize a separate Zapier step to format the incoming data accordingly to match the formatting of what you’ve manually typed. This should work!

Try out these suggestions and let me know if you continue to run into any issues.

1 Like

Hi Helen, thanks for the reply.

The formatting step is just what I was looking for thank you, I was able to format the phone number without the + which solved that issue. Unfortunately the date and time reformat doesn’t let you isolate time as data but I think that’s an issue with zapier and calendly which I’ll look into. Having date and phone numbers work is a great help, Thanks again!

1 Like


Glad to hear that Formatter helped solve the Phone column one! For the Date and Time format, Calendly is almost the correct format for our Date column. Within the Zapier column values, you are able to use both JSON formatting, and Simple (string) formatting. Since that’s the case, sending a value formatted like the below would work:

“2021-09-01 16:51:32”

You could try using a “YYYY-MM-DD HH:mm:ss” as the format. For example:

Then, the item is created in successfully:

I hope this helps as an additional pointer :slight_smile:


That’s perfect thank you, everything is working great and I understand a bit more about the process.
Thank you for your help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.