Items Query responding with error


I have a scheduled script that pulls items from our workspace with a query formed like below:

query { boards (ids: boardId) { name id items ( limit: 25 page: 1) { id name column_values { title value text id } updates { body text_body id created_at creator { name id } replies { id creator { name id } created_at text_body body updated_at } } } } }

Until recently it was working fine. Now it returns this:

  "message": "Unexpected token 'u', \"upstream r\"... is not valid JSON",
  "stack": "SyntaxError: Unexpected token 'u', \"upstream r\"... is not valid JSON"

If I reduce the number of items per page to 5, it seems to work fine, but this is an unacceptable solution as it takes far too many queries to pull all of the data. It’s already really slow at 25 per request.

Anyone know what is happening here?

Hello there @jmsmit38!

This looks odd.

Could you please send us an email to with this information and a screenshot of the query and response in your Playground so we can take a closer look?

Looking forward to hearing from you :slightly_smiling_face:


1 Like

It is very odd. I tried in the developer playground, terminal, and in our scheduled process, and the only way to get the query to work was to reduce the limit to a very small number.

I just confirmed again this morning, and it still doesn’t seem to be working…