Problem with Oauth for monday app happened first time today

We have a live app for and we are working on new version of this app. We need user to do Oauth to provide us with token for extra features(this is in draft). We never had Oauth before and in draft version was working fine with which ever url we provided in redirect uri
I know of this caveat but it was not this issue because we never had Oauth or redirect uri
Invalid redirect_uri error

Now what happened recently is the auth stopped working always giving us Invalid redirect uri error. Then I added app_version_id to auth url and it worked.

Questions: -
Is this intended behaviour?
When was this implemented?
What do I need to make or change url for auth when we go live with this version does it include version id or not?

this is very high priority please we are scheduled to launch next week and this happened when it was fine.

Please help

Hey @gary

Did you check that the Redirect URI you set in Your App > OAuth > Redirect URLs window matches the one you send in the OAuth process?

I am not sending any uri in request which should match to first in list and I only got one in list.
Please suggest if this is changed recently?


@dipro Can you please help!

Hey Gary, I don’t fully understand the flow here.

Is your redirect URL listed in the live version of your integration, or a draft?

Generally speaking, the OAuth flow will use the settings from the live version. So if you are passing a redirect_uri that is listed in a draft but not the live version, you will receive an error.

Thanks a lot for replying,
We don’t have OAuth for live version, we are adding OAuth which right now is in draft.
It worked fine with just adding URL to redirect URL tab and using the link for OAuth which was provided under Making OAuth Request. But recently it stopped working and only way I was able to make it work was using app_version in OAuth request url.

Hello @gary !

As Dipro mentioned, the redirect_uri should be listed in the live version.

Can you try adding it to the live version, and let me know if the issue continues?