CRM Emails added automatically from Gmail account

Somewhere, somehow, I have clicked on a box that is enabling all email addresses to be imported as Contacts into my CRM. How do I stop this? I have no automations set up that I can find that would be causing this. Help!

Hey @colleen928!

Are you currently using the Emails & Activities App? It sounds like this particular option is selected which is logging all new emails as new contacts in your board:

If this is the case on your end, you can simply adjust these settings to log all or specific emails in the app!

Thank you Bianca! That was it!

1 Like

Glad to hear you’ve sorted it! No problem :blush: