Dependencies - Disable new behavior (Strict/Flexible)

Hey team!
I’m really happy that we had an update regarding the behavior of dependencies. The proposed strict/flexible behavior available on the dependency column settings fixes the really slow time we had before depending on automations.

That said, it’s really important for users to be able to DISABLE this automated behavior in all dependencies. There are still several pain points that prevent us from fully “depending” on dependencies:

  • the “flexible” behavior makes us unable to have activities depending on others that overlap. With the behavior active, all dependencies can’t overlap and are pushed to start at the end of its dependency. It’s utterly important for us to be able to have Start to Start, Finish to Start, Finish to Finish dependency modes natively.
  • sometimes, adjusting dependencies change timeline dates of already completed activities. Activities checked as “done” shouldn’t be changed by automations or automated dependency changes. It’s important for us to maintain a “true history” of what happened.
  • One important feature would be to set certain activities as “frozen”/with their timelines unchangeable by automations or changes on other dependencies’ dates.

I urgently need some help on disabling for now this feature in our account. Since we have lots of dependencies that overlap, this new feature has turned our timelines upside down.

@CSG @CXS @BiancaT


hi @Admeirel

One of the largest partnerd Work Perfect has an app on the marketplace called SchedulerPro. I believe that app solves all these dependency issues. They support lag and lead (negative lag) to allow overlapping tasks.

Hey Bas,

Thank you for the tip, I‘ll give the app a try.

What I was most worried about now actually was deactivating the automated “strict/flexible” dependency behavior. I guess I can do that by erasing the dependency column and adding it again to the board.

Anyway, I think it’s really important for the monday team to solve it / make dependencies more straightforward natively.

I’m experiencing the same issue, unfortunately, and Monday help hasn’t shared a solution yet. Were you able to get this resolved for your account?

Alicia, I’ve gotten in touch with the support and they’ve suggested a workaround:
to disable the new automated behavior of the dependency column, you can create another (empty) date/timeline column and connect the dependency column to it. That way, the original timeline column won’t automatically be updated when you change dates.

The dependency feature is probably going to be updated until the end of the Q1 2023.

1 Like

Thank you so much! This is actually what I wound up doing. I created a new date column to connect to the dependency column, then I deleted that column so it’s not connected to anything. It looks like that turned the feature off, so now I just have to review all my project timelines and get them back to what they were before I turned it on :slight_smile:

1 Like