Edit Display Name on Emails Sent from Monday.com


We have been trying to use monday.com as a CRM, however, we have been having issues with how the gmail integration works. Allow me to Summarize the issues:

Whenever a new email is sent from the main gmail platform you can choose whatever name you prefer to display on the email title, for example like this:


However whenever a new email is sent from the Emails and Activities app to any person the Email looks like this on the receiving end if its a gmail account:


Or like this if its an outlook account:


Sending emails and having an inappropriate display name severely hinders the usefulness of the platform and negatively affects engagement, which is critical in outreach. People might be less likely to open or respond emails if the sender is carlos, o carlos@randomdomain.com, when compared to an email sent by Carlos from MyAwesomeCompany .

Monday has all the tools to build complex CRMs, but the problem of the emails is affecting in a very negative way the use of the platform for this end. Having the chance of changing the display name on the emails sent from the platform would help to make it more useful and to stop doing outreach from the email directly.

Similarly, the tracking features would be a lot more interesting if not only an opening track was added, but also a tracker for links and if possible, files.

The Emails and activities app needs some work in order for it to be better for sales, and if it gets to that point it would become super useful and a solid choice for CRMs.


Is there a solution for this? I am faced with the same problem.

Thank you.

I’m having some of the same issues and now Gmail isn’t working at all. I’m receiving an error “The email was not sent.” No explanation and I can’t find anything on that error here in the forum.

Ideas anyone?


No there isn’t at the moment. I spoke to monday’s CS and they told me it wasn’t possible.

1 Like

Surely this has been sorted by now? When I send emails through Monday CRM the recipient just sees the sender as “joe”. How do we change this?

There isn’t any solution for this at the moment. Sadly.

This is a bit frustrating. I have a competely irrelevant name showing up (an old gmail account owner’s name), and I can’t do anything about it.

In Gmail, go to settings>All settings>accounts and click on edit info where it says “Send Mail As”. In there, select the second radio button and type your desired name in there manually. Don’t use the automatic one because Monday doesn’t pick it up. That should work.

1 Like

This works!!!

Thanks! :smiley: