Formatting Formula Columns within Subitems ($, %, etc)

Hey there,

I am working with subitems and am struggling to format the numbers that are displayed in the output. With ‘items’, it is easy to click the summary section and select '$" or “%” for example, however with subitems I can’t seem to see that option.

I read in another thread that you can use the ‘TEXT’ function to display the dollar sign and decimal formatting, but I can’t seem to make it work with dynamic columns.

This is my current formula resulting in an error:

TEXT(({Shopify F2}*({RRP}+{Shipping}))+{Shopify F1},“$#,##0.00”))

Any ideas anyone?

Hi @thedigitalgrowthco
Welcome to the community & Happy New Year
If i am understanding the requirement correctly
You should be able to use the below formula
Hope this provides what is needed
Let me know if you need any additional help
Many thanks in advance

Screenshot 2023-01-03 at 12.54.23

Ok, Follow up question here from another user. Using this formula (or somehting similar) I’m able to get the formula column to display the $.

Text({Retaining Wall Value}+{Processed Fill Value},“$,###.##”)

However, I now want a column summary. Because this is a subitem I can only display the summary on the parent Item. The summary display on the parent item just shows 0 and doesnt have a $.

Welcome to the community
Simplyfying the formula to just Mathematical and setting the unit value to $ should roll up the sum on the parent calculation
Hope this helps
Many thanks Dan
Screenshot 2023-01-09 at 10.29.00
Screenshot 2023-01-09 at 10.29.18

Using the formula column, setting the unit is not available.
I’m trying to multiply two sub columns for a total, then display that total or mirrior that total in the parent item.

The problem with the Text function is that, as its name implies, it converts the numeric value to text. Because it is now text, your summary shows 0 (it can’t sum up text values). If you remove the Text function from the formula, you’ll see that your summary will work (without the $ sign) and, of course, you won’t have the $ sign anymore at the subitem level…

Ok, yes I can get the equation to work without the $ sign. So I’m assuming in my case there is no way for the $ sign to be displayed. Multiplying two sub columns for a total and then displaying that total on the parent item.