Monday.com Form, Capturing Signature and putting in PDF

We have created a form, and on that form is a signature where the tech signs it stating that he has completed a certain task. We used the signature question on Monday.com and everything works great - except that the PDF that we need to show the client displays “image.png” instead of the signature itself. Is there a way to display the signature on the PDF?

I would love to know how you are inserting a field for the tech to sign. I’m right there in creating a form right now!

Hey Tony!

Welcome to the Community - thanks for your question :slight_smile:

So that we can ensure we are on the same page, are you able to clarify which column you’re using for the tech to input his signature? Additionally, are you able to let us know how you’re downloading the form?

We look forward to hearing from you.

Best,
Bianca

@BiancaT I am having the exact same problem, if you wouldn’t mind answering for me as well…

In the “Form view”, when you click “add a new question” there is an option to add a “signature”.

You can then click on “Form Response Viewer”, when you click on that view, there is a button that says “Download as PDF”. When you open the PDF, the signatures don’t show up on the PDF, it just shows up as “signature.png”.

Is there a way to make those png files show as the signatures?

Thanks so much!

Hey @lindsayjeans,

Firstly, welcome to the community! :smiling_face:

In regard to the roadblock you’re experiencing, I too have been able to reproduce this behavior when downloading forms that include signatures. Please allow me to follow up internally, and update you once we hear back from our specialist team.

Thank you in advance for your patience!

Best,
Bianca

Thank You Bianca, I would really appreciate your help on this!

Lindsay

When will this issue be resolved?

Hi @lindsayjeans and @kconlon,

Apologies for the delayed update! Whilst I am still waiting on confirmation from our developers, it does appear that at this time it is expected that signature will not display on the PDF. I certainly recognise that this is clearly not ideal, and will ensure this feedback is discussed with our product team. I am sorry for the setback!

Once I hear more from the developers, I will be sure to update this thread.

Best,
Bianca

1 Like

Hey,

It seems as this issue bother many users and I wanna add myself to this list.

I don’t understand the point of capturing signatures on a form if it cannot be displayed. in what way having a signature file without the content/terms of which the signature was captured with serve anyone?

DO you anticipate that this will be resolved anytime soon?

Thanks in advance!

1 Like

Hey @HBG, @lindsayjeans and @kconlon,

Thanks for your patience with us while we waited to hear from our developers.

That said, the team have confirmed that they’re aware of the setback, and that there are plans to refactor the signature into the workforms result, so that it pulls when exporting to PDF, however at this time, they cannot confirm a specific timeline for this feature release. I apologise for the lack of clarity here, however please be assured that the team hope to support this functionality in the near future.

Thank you in advance for your understanding!

Best,
Bianca

1 Like

Can you provide more information on “signature question”? Not seeing how to do this. Thanks!

Hey @hrix!

By navigating to workforms and ensuring you’re in edit mode, you should have the ability to add the signature question as shown below:

Let me know if you run into any issues!

I am glad to see I am not the only one experiencing the same problem.

I would like to see if anyone had any update regarding this.

1 Like

I second Jason. Wondering if there will be an update coming soon?

@BiancaT Has there been any update to this?

2 Likes

@BiancaT Hi good day - I’m also experiencing this issue and wonder if there’s been an update? Last response from the technical team I believe was in December? Thank you.

@BiancaT Is there any update on this? I would love to be able to use this.

Hi everyone! Apologies for my delay in responding - thank you for your patience! I just wanted to let you know I’ve just followed up with our developers on this and will circle back here as soon as I get a response :pray:

Hey everyone, thanks for your patience with me! I have heard back from the dev team who confirmed that as of now this particular feature improvement is not immediately planned, due to other priorities and team capacity - however it is being considered in our next iteration. I understand this isn’t the concrete confirmation you may have been looking for however we will be sure to keep you in the loop as we’re made known to new developments. We appreciate your understanding in advance!