Webhook not triggering Zapier

cope_webmanager@publicationethics.org

11 Aug 2021, 12:23 UTC

I have 3 boards on Monday: the first board is where event registrations are imported and the administrator confirms that users are members (as only members can attend the events) - selecting Yes or No in a status column on this first board moves the record via a Monday automation to a different board: either ‘Registered’ or ‘Non-members’. I have set up Monday integration with Zapier so that when a new Item (Pulse) appears on the Registered Monday board, an email is sent with the Item data via Gmail (sent to the registrant to confirm the sessions they are registered for).

I have tested this on numerous occasions and the tests all working fine. The issue is after I activate the Zap, and seems to be with the webhook/trigger not working. Zapier shows no tasks/run history for the Zap. (This is the first time I have used a webhook, so maybe I’ve not set things up correctly?) I followed all of the instructions in the Guide ‘Zap isn’t being triggered’, on Zapier - no change.

The Zap has no errors; it should be an Instant trigger. I have repeatedly switched the Zap on and off, and have created a new record after switching the zap on each time. I’ve also been trying to find a solution for almost 24 hours…so any help would be much appreciated. Thank you!

Hi @scoobysnack,

Do you mind providing a screenshot of your Zapier integration setup? I’m curious to see what trigger you’re using to pull this data from.

If you’re using a Zapier trigger block, I don’t believe you would be needing a monday.com webhook integration on your board as well.

Let me know!

1 Like

Hi @scoobysnack,

Since it’s been a little over two weeks since we last heard from you, I’m going to mark my first comment as the solution and close this out.

If this has not been resolved, feel free to comment on this thread within a week, start a new thread, or email into appsupport@monday.com.

Thanks!

Hi @Helen so sorry for the sloooooow response, especially when you were so prompt!

I contacted Zapier at the same time and they replied with:

The issue here is that the “New Item in Board” trigger will only trigger on brand new items on that board. In other words, if it was created on Board A, and moved to Board B, it will not trigger any Zaps watching for new items on Board B.

I’m afraid the bad news here is that we’re not currently able to trigger on items moved to boards in monday.com. We’re always looking for ways to make our integrations more powerful and it sounds like this could be really useful for others as well, so much so that it’s already one of the top feature requests for this app.

I’ve added your email address as another vote for this addition. I don’t have an ETA of when or if this will happen, but we will definitely email you if it does become a reality.

After receiving this information I managed to create a workaround (might help anyone else in a similar situation):

On the import board when Yes or No is selected, instead of moving the Item, I am using a Monday automation to create a new Item on one of the other boards - exact copies of the import item. (if Yes, the item is created on the Registered board, if No, it is created on the Non-members board). I then have two zaps, one for each board, watching for new Items, wich are the triggers for the respective emails.

It’s a bit of duplication but we can delete them in bulk from the original import board as soon as they have been assigned Yes or No for membership status. It’s working well and is now using 2 tasks per zap, instead of 3 in my original solution, so better in that respect.

1 Like

Hi @scoobysnack,

Thank you so much for posting your workaround! This is going to help a lot of our users who face the same issue.

I’m glad to hear that you were able to resolve your issue. Please do let us know if there’s anything else we can chime in on and help with at this time!

1 Like

@Helen I’m sure you’re right, but I started from Integrations in Monday, and followed the instructions here: How to create an integration using Zapier – Support which seemed to create new webhooks.(?) (multiple becasue of my failed attempts to get it to work so I started again several times thinking I must have missed something… :joy:)

Proably my lack of knowledge of Monday integrations. :grimacing:

Thank you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.