Zapier Column Value Changed in Board not registering triggers

Ive been trying to set up a Zap from monday.com to GetAccept (on behalf of a client) when a status changes.

I do not really understand what is wrong. I change the desired status and ask Zapier to load more events, but I always get the exact same event, the only difference is the board ID referencing the correct board.
What am I doing wrong? Anyone have any idea?

Thanks in advance!

event
app
monday
boardId
605889190
changedAt
1564587898.712963
columnId
status
columnType
color
pulseId
983678
userId
NNNNNN (Manually changed)
type
update_column_value
value
label
index
1
text
Done
style
border
#00B461
color
#00c875
var_name
green-shadow
previousValue
label
index
2
text
Stuck
style
border
#CE3048
color
#e2445c
var_name
red-shadow
1 Like

Hey @Thomas-Omnitas – thanks for posting!

The data you’re seeing is dummy data that is hardcoded into the “test” stage of the module. It’s feedback that we have received before and are investigating how to resolve.

To make the integration work right now, I’d suggest connecting your Zapier integration and then running the connection (instead of pressing the test button).

What do you think?

Thank you @dipro. The problem is that I use Zapier because I am no coder. I want the test in order for Zapier to pick up proper data making it easier for us none developers to use Zapier. With other apps I can use the test data to get the sources correct without having to consult the API documentation.

What should I do to have the “Column ID: status” trigger the integration when the status is changed to the light Purple color with the label “2. Business Proposal”? I cant seem to find any way to specify which column value change I want to be the trigger in Zapier.

Thanks in advance for further assistance!

1 Like

I’m experiencing the same issue. Despite changing column values, the new data doesn’t register in Zapier. Help?

Currently having the same issue, I’ve been keeping a regular watch on it but seems to still not be solved.

Has there been any joy with this issue?
Being able to use the new API will be huge for how we use Monday and once it’s working properly I doubt we’ll ever move to another program.

No official reply since @dipro wrote 30 days ago.

Same issue, only seeing the dummy data.

Same issue, but not clear what you are suggesting as a fix?

The Zapier integration is already connected. The only way to run the connecting in Zapier is to press the test button, it doesn’t allow the Zap to be completed without it afaik.

Hey @dipro

I tried moving past the test part, however when I get to the “Do this…” step, Zapier hasn’t got all the available fields from my board, so I can’t complete the Zap as I can’t select all the fields I need to be used in the Zap.

I’ve checked that I’m using the right Board ID and I’ve tried refreshing the fields in the Zap manually, even waiting up to 30 minutes in case the changes in Monday.com are taking some time.

No luck.

At this point the Zapier integration seems useless until they fix the underlying problem.

+1
I’m having a similar problem. Thought I just didn’t know what I was doing! I’m somewhat relieved to see that it’s not me, but frustrated that there doesn’t appear to be a solution.

Hi, quick update…

I’ve been working with Zapier support over the last two weeks and we’ve made some progress in narrowing down the problem.

We’ve successfully bypassed the first placeholder data issue in step 1 (Find Data) and have changes triggered in Monday.com coming through to Zapier (viewable in Task History).

The second issue we have found after bypassing the first, is that the Monday.com v2 APIs are not passing through all the board fields when something changes on a particular pulse.

For example, our test case is that we have a Status and Email field on a board. When the Status changes to ‘Done’ on a pulse we want to send an email from Zapier to the email address in the Email field on that same pulse.

The issue is that when you change the status in Monday.com, the APIs only pass through the changed field along with a couple of core fields. However the email field is not passed at all.

The only way we have been able to make any of the other fields on the board get passed through is by changing the specific field directly. However, again, it only passed through the core fields plus the changed field. So in this example, there is no way to get the Email field value when the Status field value is what’s changed.

This is a limitation with how the APIs operate with Zapier and unfortunately there is no solution on the Zapier end. This needs to be fixed by Monday.com.

Ideally what should be happening is that anytime there is a change triggered on any field on a board, the APIs should pass through ALL the fields for the changed pulse to Zapier.

We’ll have to leave the Zapier integration for now and try again once Monday.com has made improvements to how the APIs integrates with Zapier.

1 Like

just to add… the other solution might be to offer a ‘get pulse’ type action in Zapier so that you can add an extra step in the Zap and use the pulse id from the trigger data to get all the fields for that pulse item. This could work also.