Zapier + monday API v2 Longtext problem

I am experiencing problems with Zapier (monday API v2) and posting content into a Longtext column. The Zap works fine if the Longtext column value is blank or within the limit of a normal text column. I have checked and the text we are trying to send a cross is less than 2000 letters.
Keep getting the “Internal Server Error”. I am 99% sure it is the longtext, because as soon as I remove that one I can re-run the Zap.

This is what the Zapier Column value looks like:
{“epost4” : {“email” : “FORM DATA FIELD”, “text” : “FORM DATA FIELD”}, “gatuadress” : “FORM DATA FIELD”, “text9” : “FORM DATA FIELD”, “text07” : “FORM DATA FIELD”, “text6” : “FORM DATA FIELD”, “produkt4” : {“labels” : [
“FORM DATA FIELD”]}, “quantity” : “FORM DATA FIELD”, “check” : {“checked” : “true”}, “message” : {“text” : “FORM DATA FIELD”}}

This is the Latest form submission that is being Stopped with the "Internal Server Error"
board_id: 606142701

group_id: new_group70760

item_name: First Name Last Name

column_values:
{“epost4” : {“email” : “email@gdpr.se”, “text” : “email@gdpr.se”}, “gatuadress” : “NNNNNNNNNN”, “text9” : “Street Adress 2”, “text07” : “NNNNN”, “text6” : “Region”, “produkt4” : {“labels” : [ “Grindar och staket”]}, “quantity” : “2”, “check” : {“checked” : “true”}, “message” : {“text” : “Hej! Vi undrar vad det kostar att få en Bollerup pargrind, anpassad i bredd och med gångjärn för befintliga stenstolpar, avstånd mellan stolpar ca 380 cm, C-C mellan gångjärn ca 370 cm samt en gånggrind med stolpar, 125 cm total bredd?”}}

(I have modified the data to remove personal information from the clients client.)

Please advice what is going wrong with the longtext message.

Thanks!
@dipro

After additional testing I can now confirm that it is the row breaks (blank spaces) in the long text message that prevents the Zapier to go through

This got blocked:
"Hej!

Vi håller på att bygga om ett gammalt garage till uterum/orangeri. Jag undrar om ni kan hjälpa oss med ett dörr- och fönsterparti för en öppning som är 3000x2600mm (BxH). Vi ser framför oss ett skjutdörrsystem i 4 delar + ett fast fönsterparti ovanför, men är spåklart öppna för kreativa förslag.

Kontakta mig gärna om ni vill ha mer information och/eller bilder etc.

Tack på förhand!
Med vänlig hälsning"

This got through:
“Hej! Vi håller på att bygga om ett gammalt garage till uterum/orangeri. Jag undrar om ni kan hjälpa oss med ett dörr- och fönsterparti för en öppning som är 3000x2600mm (BxH). Vi ser framför oss ett skjutdörrsystem i 4 delar + ett fast fönsterparti ovanför, men är spåklart öppna för kreativa förslag. Kontakta mig gärna om ni vill ha mer information och/eller bilder etc. Tack på förhand! Med vänlig hälsning”

This has to be fixed some how… Is there anything I can do in Zapier or does it require an API update?
@dipro

I am having a ton of issues as well with re-connecting my zapier workflow once the APIv2 was updated. I am not familiar with JSON so I haven’t been able to reconnect my zaps how I had them before.
Are you using the “update multiple column values” trigger in the zap? I am trying to use how you set up your merge tags so I can try to figure it out on my end as well. Glad I am not the only one having issues with this.

Hey @Thomas-Omnitas :wave:

monday.com’s API won’t accept line breaks when setting column values for a Long Text column. So this is a change that would need to be made to the API as opposed to the Zapier integration.

With this in mind, I’m curious if you’ve checked out Zapier’s Formatter steps? In full transparency, I have not used the Formatter to remove line breaks, but this article makes it sound like it’s one of the intended use cases - https://zapier.com/blog/zapier-formatter-guide/

Specifically this part of the article:

Zapier’s Formatter Replace function can do that for you. Add a Formatter Text action to your Zap, select the Replace transform, and tell Zapier what text you want to search through. Then tell the Zap what you want to find—anything from text to spaces to line breaks. Finally, add what you want to replace that text with—or leave it blank to have Zapier just remove that text.

I’d love to hear if this works for you!

-Scott

Hey @mmalone :wave:

I’m curious if you’ve checked out our Zapier JSON formatting guide? :slight_smile:

You can find it here - https://support.monday.com/hc/en-us/articles/360014205860-Zapier-JSON-Formatting-Examples

Let me know if there’s any specific column types you’re working on JSON formatting for that aren’t covered in that article!

-Scott

@Scott-monday.com That is quite a serious shortcoming in the API. Clearly that has to be a oversight since the whole purpose of a Long text column is to allow for 1) longer text as well as 2) line breaks. And linebreaks in longtext works perfectly well when using mondays own forms.

I tried the Zapier text formating. Good idea. However it didnt work. I was able to perfectly remove the line break and make the text one continuous string. But for some reason it still doesnt allow posting to the long text. I tried all combinations and can clearly contribute the stopped action to the linebreaks, and there seem to be some kind of code still that prevents it from going through even after I do the replace newline formating.

Find [:newline:] replace with null = delete.

{“Long text Column ID” : {“text” : “Reference to Zapier formatter output”}}

Tested with up more than 1000 letters, works perfectly to post, but if I add one line break to the same text the Zap fails.

I have tried and found a few more articles but I have zero experience with JSON so I don’t even understand what I am looking at. I have been back and forth with Zapier support for over 2 weeks trying to fix all of my zaps because of this new update. And I still haven’t been able to get it fixed/figured out yet.

having maybe a screenshot example of Zapier would help me better understand how the data needs to be set up, the article is not helpful in that sense. Doesn’t show me where to put what.